Finding the correct patch version of a Lync server

adhesive_bandage-512Recently I have been troubleshooting and doing health checks on a couple of Lync systems. When troubleshooting it is good to know what patch level your servers are on, whether they are on the same patch level or the newest patch level.

I discovered at one client that the Edge servers in DMZ was being patched through Windows Update, but the internal Front End servers where not being patched, they where not part of the patch system the customer where enforcing. The result was that at one point, with the january 2014 cumulative update on the Edge server and the RTM patch level on the Front End servers, the gap became too large and the it ended up with the Front End servers not supporting and working with the Edge AV relay server. We saw the error occur with unsupported realy server in the diagnostics header before the Front End servers even tried setting up the media traffic on the Edge servers.  Quite a strange problem to troubleshoot, but best practice is that all servers should be on the same patch level. Patching the internal Lync servers solved the issue.

Here is some notes on finding what patch level your servers have

One thought on “Finding the correct patch version of a Lync server

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s